読者です 読者をやめる 読者になる 読者になる

山崎屋の技術メモ

IT業界で働く中で、気になること、メモしておきたいことを書いていきます。

【Eclipse】Java compiler level does not match・・・のエラー

eclipse java

f:id:yyama1556:20160827114434j:plain


Eclipse でプロジェクトの JRE バージョンをいじったりすると次のようなメッセージが表示されることがある。

Java compiler level does not match the version of the installed Java project facet.

今回は Java のバージョンを 1.6 から 1.8 に変更したら出た。

f:id:yyama1556:20160827113727p:plain

このエラーが出てしまったときの対処方法をメモしておく。

修正方法

Package Explorer でプロジェクトを右クリックして、Properties を選択する。プロジェクトを選択して Alt + Enter でもOK。

Properties 画面が開くので、Project Facets を選択する。

f:id:yyama1556:20160827114730p:plain

Java の version が 1.6 になっているのでこれを 1.8 に直して OK ボタンをクリックする。

f:id:yyama1556:20160827114933p:plain

これで直った。

以上。

JavaデベロッパーのためのEclipse完全攻略 [4.x対応版]

JavaデベロッパーのためのEclipse完全攻略 [4.x対応版]